Datos personales

Mi foto
Colonia Caroya, Córdoba, Argentina
Ingeniero en Sistemas de Información

09 febrero 2009

Instalar Internet Explorer 8 RC1 y no morir en el intento...


El pasado 23 de Enero, Microsoft libero la versión RC1 (Release Candidate) del Intenet Explorer 8.

Aunque no presenta grandes cambios con respecto a su ultima Beta 2, esta versión es algo más ligera, con un consumo menor de memoria y una mejora en la velocidad al abrir nuevas pestañas.

Se observan algunas "innovaciones" importantes con respecto a su versión 7, como el modo privado, el modo de compatibilidad automático, recuperación de caídas, prevención de ClickJacking, etc... es decir, se puso al día con lo que ofrecen sus competidores directos.


Aquí pueden encontrar la versión para XP y en la misma pagina hay enlances para los distintos sistemas operativos, pero aun no para Windows Seven.

Si bajan el instalador y lo ejecutan observaran, en la mayoría de los casos, lo siguiente:



Bueno, no es la gran cosa.. no? acá preguntan si desean enviarle información a Microsoft sobre el uso del navegador, el proceso de instalación y vaya a saber que cosas mas...

Pasemos a la siguiente pantalla..





Bueno, acá tampoco pasa nada del otro mundo... comprueba si había algunas actualizaciones o sofwtare mal intencionado y luego comenzo a instalarse, todo normal.. hasta que de pronto:





Aparece lo que si quería mostrarle... en la mayoría de los equipos el proceso de instalación falla, y si teníamos la versión Beta 2 instalada la desinstala y quedamos con la versión 7...

Como verán, quedamos con los ojos como un 2 de oro, sin saber bien que paso, ya que esa pantalla solo nos dice que no se completo la instalación y el circulito rojo nos da la idea de que fue por un error... pero nada mas...

Y la pregunta es... que paso? se puede probar esta RC1 de alguna manera?

Si aun quieren probar esta versión y no pasarse a la beta 2 de firefox, sigan leyendo que hay respuesta para las dos preguntas....

Para eso veremos el log de la instalación... practicamente todos los productos de Microsoft dejan un archivo log en la carpeta de Windows con lo que paso en el proceso de instalación. Así que veremos que dice el archivo ie8.log

Podemos hacer eso rápidamente presionando win + r y poniendo lo siguiente:




(como estoy bueno se los pongo acá para que puedan hacer un copy & paste: %windir%\ie8.log )

Eso nos abrirá el Block de Notas con el log y al final del mismo podremos ver la causa del error:



Pasado en limpio, lo que dice es:

"No se puede escribir la clave del Registro de configuraciones"

Y esto pasa en la siguiente rama del registro que es la que esta marcada en la imagen:

HKCR\Interface\{34A715A0-6587-11D0-924A-0020AFC7AC4D}

El registro de windows, al cual podemos acceder con el comando regedit permite definir que ciertas ramas sean de solo lectura o de lectura escritura para algunos o todos los usuarios. Lo que paso fue, que el proceso de instalación quiso escribir un valor en una rama que tiene definido sus permisos como de solo lectura.

Como se imaginaran para solucionar este problema solo hay que cambiar ese permiso.

Para hacerlo, ingresamos al regedit de la manera que mas le gusten, por ej poniendo regedit desde la ventana ejecutar.

Una vez en el registro, vamos a la opción de búsqueda y ponemos la rama que marco el error, la que vimos en el log, en este caso 34A715A0-6587-11D0-924A-0020AFC7AC4D y presionamos el botón de búsqueda, al cabo de unos segundos el árbol del registro estará posicionado en esa rama. Hacemos click derecho sobre la misma y elegimos la opción de permisos como vemos en la siguiente imagen:




Luego nos mostrara la siguiente pantalla donde marcamos la casilla de "control total" tal como muestra la imagen:






Presionamos Aceptar, y listo, tarea concluida... bueno casi, ejecutamos el instalador nuevamente... y..





Ahora si, tarea concluida, ya pueden disfrutar o sufrir este nuevo hijo de Microsoft.

Una ultima aclaración o curiosidad... si la instalación de Windows XP no tiene instalado el SP3, la instalación ocurre sin problemas, supongo que eso se debe a que el SP3, agrega la funcionalidad de los permisos en el registro, que es la causa del fallo.


Que tengan un buen día.

Marce


5 comentarios:

Shorty dijo...

hola en vdd muchas gracias por haber hecho este blog con esta explicacion sinceramente nunca me habia querdfio meter en cuestiones del sistema y ahora que lo hice reulto tambn claro esta a tus pasos k fueron claros y concisos espero k sigas poniendo cosas asi de interensates en vdd muchas gracias

Anónimo dijo...

Muchas gracias. Excelente explicación y la necesitaba!
salu2

Anónimo dijo...

Todo bien, pero el safari 4 ya salió al mercado y lo he estado probando esta muy bueno, lo recomiendo

Anónimo dijo...

Hola hice todo lo que recomendaste pero no funciona xfa ayudaaaaa!

Anónimo dijo...

Tres intiresno, gracias